Free and Open Source real time strategy game with a new take on micro-management

Difference between revisions of "Download and Install"

From Globulation2

Jump to: navigation, search
(Downloads)
Line 1: Line 1:
 
{{Translations|View this page in|Article=Download_and_Install}}
 
{{Translations|View this page in|Article=Download_and_Install}}
  
{{Message|Beta 4 0.9.4.3 Released|Beta 4 0.9.4 was released with a corrupt tutorial 3, causing crashes on many computers. The tutorials have been updated and fixed and put in 0.9.4.1. 0.9.4.2 fixes 2 crash bugs in the editor and 0.9.4.3 fixes a rare crash in game.}}
+
{{Message|0.9.4.4 Released|0.9.4.4 has been released, fixing an issue with YOG not displaying IRC users as it was supposed to. [[Changes|View all changes]]}}
  
 
If you have installed the game but still have problems running it or if you cannot compile the source distribution, try to look at the [[Frequently Asked Questions]] page, which contains a section related to installation problems.
 
If you have installed the game but still have problems running it or if you cannot compile the source distribution, try to look at the [[Frequently Asked Questions]] page, which contains a section related to installation problems.

Revision as of 01:23, 31 August 2009

English | Français | Deutsch | Español | Italiano | Česky | Română | Русский | Català | Suomi | Japanese | Русский | Chinese

0.9.4.4 Released: 0.9.4.4 has been released, fixing an issue with YOG not displaying IRC users as it was supposed to. View all changes

If you have installed the game but still have problems running it or if you cannot compile the source distribution, try to look at the Frequently Asked Questions page, which contains a section related to installation problems.

Looking for the latest development source code? See the Compiling page for information on how to download and compile from our Mercurial repository. From time to time we do development snapshots, too but be aware that those are not yet released for a reason.


Downloads

Source
http://www.globulation2.org/wiki/images/1/18/Source_download.png
Beta 4 (0.9.4) (outdated)
glob2-0.9.4.4.tar.gz
Latest: SCM
Compiling Instructions
Linux
http://www.globulation2.org/wiki/images/e/ea/Linux_download.png
see below ...
Windows
http://www.globulation2.org/wiki/images/2/24/Windows_download.png
Beta 4 (0.9.4.1) (outdated but still compatible)
glob2win32-0.9.4.exe
Mac
http://www.globulation2.org/wiki/images/a/a1/Mac_download.png
Beta 4 (0.9.4) (outdated)
Universal Binary
or
MacPorts

You can still download the Older Releases. They can be useful if you want a binary for a system for which the latest release has not been packaged yet.
Please keep in mind that Internet game will most likely not work with older releases. (See What version should i choose to play in the FAQ.)

Linux Distribution Packages

Following packages may be out of date: The following packages and/or console commands to install Globulation 2 on Linux distributions may out of date. To obtain the latest version (if you can't get it from below), we suggest compiling from source if you're using Linux.
Mandriva
http://www.globulation2.org/wiki/images/9/90/Mandriva_download.png
Beta 3 (0.9.3) (outdated)
2009.1: i586/x86_64/source

To install from the Mandriva repository, run as root
urpmi globulation2
Fedora
http://www.globulation2.org/wiki/images/e/e5/Fedora_download.png
Beta 3 (0.9.3) (outdated)
Core 11: i386/x86_64/source

To install from the Fedora repository, run as root
yum install glob2
Gentoo
http://www.globulation2.org/wiki/images/3/30/Gentoo_download.png
Beta 4 (0.9.4.1) (outdated but still compatible)
Ebuild: glob2-0.9.4.ebuild (portage)

To install from the Gentoo repository, run as root
emerge glob2
Debian

http://www.globulation2.org/wiki/images/b/b3/Debian_download.png
Beta 3 (0.9.3) (outdated)
Lenny: i386/amd64

To install from the Debian repository, run as root
apt-get install glob2

Alternatively, download one of the packages above, then run as root dpkg -i glob2_VERSION.deb. If you get any dependency errors, resolve them and try again.

Also, see .deb packages for Ubuntu. They may install properly.

Beta 5 (0.9.5RC) (release candidate)
i386

openSuSE
http://www.globulation2.org/wiki/images/3/34/SuSE_download.png
Beta 4 (0.9.4.1) (outdated but still compatible)
Packman repository

To install from the openSUSE repository, run as root
zypper install glob2
Or click the following link to use openSUSE 1-click-install: 1-click-install glob2

If you encounter any issues with the openSUSE packages, contact the Packman team.

Ubuntu
http://www.globulation2.org/wiki/images/a/a2/Ubuntu_download.png
Beta 4 (0.9.4.1) (outdated but still compatible)
Hardy: i386/amd64 - data

To install from the Ubuntu repository, run as root
apt-get install glob2

Alternatively, download one of the packages above, then run as root dpkg -i glob2_VERSION.deb. If you get any dependency errors, resolve them and try again.

Also, see .deb packages for Debian. They may install properly.

If the above links aren't working, you can try: another Globulation Beta 4 source.
FreeBSD
http://www.globulation2.org/wiki/images/c/c3/FreeBSD-logo.png
No Download Available

A port exists and binary packages are built for different platforms. See FreshPorts.
Slackware
http://www.globulation2.org/wiki/images/5/59/Slackware-logo.png
Beta 3 (0.9.3) (outdated)
12.1: i686
Archlinux
http://www.globulation2.org/wiki/images/5/56/Archlinux-icon.png
Beta 3 (0.9.3) (outdated)
AUR: i686
To install from the Archlinux repository, run as root
pacman -S glob2